下載 Linux版

最新的發行版本為 4.1.0. 新鮮事.

請不要使用發佈者所提供的 calibre 封裝, 那些通常都有 Bug、而且過時。請使用下方所述的二進位安裝方式進行。

二進位安裝

calibre has a binary install that includes private versions of all its dependencies. It runs on 32-bit and 64-bit Intel compatible machines. To install or upgrade, simply copy paste the following command into a terminal and press Enter:

sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin

在您等待下載完成時候,您可以考慮看看是否要贊助 calibre 的開發工作。

注意

  • 如果出現錯誤顯示「未受信任的憑證」,這代表你的電腦可能並未安裝根憑證,所以無法安全地下載安裝檔。如果還是想要繼續,請在 wget 加上 --no-check-certificate 選項,就像這樣:
    sudo -v && wget --no-check-certificate -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin
  • 您必須在安裝前把 xdg-utils、 wget、 xz-utils 以及 python ≥ 2.6 在電腦上安裝好。
  • You can uninstall calibre by running sudo calibre-uninstall. Alternately, simply deleting the installation directory will remove 99% of installed files.
  • You need GLIBC 2.18 or higher and libstdc++.so.6.0.21 (from gcc 5.4.0) or higher to run calibre
  • You can change the directory calibre is installed into from the default (/opt) like this:
    sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin install_dir=/opt
    Change /opt above to whatever directory you want calibre automatically installed to.
  • You can also do an "isolated" install that only touches files inside the installation directory and does not need to be run as root, like this:
    wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sh /dev/stdin install_dir=~/calibre-bin isolated=y

Reverting to a previous version

You can install a previous calibre release, like this:

sudo -v && sudo calibre-uninstall && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin version=3.48.0
Change 3.48.0 above to whatever version you want installed.

Manual binary install

If you wish to revert to an earlier calibre release or download a calibre upgrade manually, download the tarball of that release from here (choose the 32-bit or 64-bit version, as appropriate). Assuming you want calibre in /opt/calibre, run the following command, changing the path to calibre-tarball.txz below as appropriate:

    sudo mkdir -p /opt/calibre && sudo rm -rf /opt/calibre/* && sudo tar xvf /path/to/downloaded/calibre-tarball.txz -C /opt/calibre && sudo /opt/calibre/calibre_postinstall
    

原始碼安裝

WARNING: calibre is a highly complex piece of software with lots of very finicky dependencies. If you install from source, you are on your own. Please do not open bug reports or expect any form of support. You have been warned.

如果你還是決意要從原始碼安裝,請看下去:

  1. 確認系統上已經安裝了python 2。
  2. 安裝好下列幾個相依性 (dependencies) 清單
  3. 在終端機內執行下列命令:
curl -L https://calibre-ebook.com/dist/src | tar xvJ 
cd calibre*
sudo python2 setup.py install
        


相依性 (Dependencies)

官方的 calibre 二進位版已經包含了最新版相依性的清單在內,可以在sources.json檢視。 雖然 calibre可能使用了在清單所列出以外的版本還是可以運作,但是並未經過測試、也不受支援。 另外,這些相依性在編譯期間需要使用像是 pkg-config、 C/C++ 之類的編譯器來進行作業。

請選擇您所屬意的語言